jna-platform dependency

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

jna-platform dependency

amake
This post has NOT been accepted by the mailing list yet.
Hello. I have a question about the jna-platform dependency.

I have an app that uses svnkit 1.8.5 and jna 3.5.2, but does not include jna-platform or jsch.agentproxy.*. I am looking at upgrading svnkit to 1.8.12, which requires jna 4.1.0. I am wondering if jna-platform is really required as well.

It looks like com.sun.jna.platform.* classes are not used at all in svnkit source, and in fact jna-platform is only required by jsch.agentproxy.pageant. So then perhaps the reason jna-platform 4.1.0 is specified as a top-level dependency is purely to ensure it's the same version as jna?

In that case am I OK to include jna but not jna-platform as long as I am also not including jsch.agentproxy.pageant?

Thanks,
Aaron