Checksum mismatch with 1.9.7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Checksum mismatch with 1.9.7

Michael Knigge-2
Hi all,


I have a rather strange issue with Subversion 1.9.7 and I hope someone
of you can bring me in the right direction. I'm not able to load a dump
and/or svnsync to a new Subversion in version 1.9.7.


I create a dump on the server running 1.8.19 and try to load it on the
1.9.7 machine. Then I get an error:


svnadmin: E160004: Filesystem is corrupt
svnadmin: E200014: Checksum mismatch while reading representation:
    expected:  3168c2eb460868be4ec2e1a62084d80f
      actual:  67178f4abfbb0b876a260142c15f645b


I also get this error when i run "svnadmin load" with the "-M 0"
trick... On another machine running Subversion 1.8.10 I can load the
dump. So the dump is ok (furthermore, a "svnadmin verify" on the 1.8.19
server also runs successfully). Note that I was able to expoprt the file
from this revision (Windows with TortoiseSVN) and the checksum is
3168c2eb460868be4ec2e1a62084d80f - so the "expected" checksum in the
dump is ok.


Ok, I was not able load load the dump - so I tried svnsync. On the same
revision, the svnsync also stops:

svnsync: E160000: SHA1 of reps '51384 62 16385 20282
3168c2eb460868be4ec2e1a62084d80f
cc1652eaf2ef8cb91769dc4fea2d327413548c3e 51384-13nc/_21' and '-1 0 934
20282 3168c2eb460868be4ec2e1a62084d80f
cc1652eaf2ef8cb91769dc4fea2d327413548c3e 51384-13nc/_21' matches
(cc1652eaf2ef8cb91769dc4fea2d327413548c3e) but contents differ


I've searched the Mailing-List archive and came across other people
having problems like this (but for them "-M 0 " did the trick). Sadly,
not for me....

Ok... what now? Is there a bug in 1.9.7? Or is Subversion on the server
side too old? Any ideas?


Bye & Thanks,
Michael

Reply | Threaded
Open this post in threaded view
|

Re: Checksum mismatch with 1.9.7

Paul Hammant-3
Well done for trying experiments so far.

One more perhaps?  
1. Make a new machine that is also 1.8.19.  
2. Restore the dump file into that. 
3. Upgrade that Subversion to 1.9.7 - following advice in the release notes for repo upgrades too 
4. Make a dump file again on that new machine. 
5. Try to restore that new dump file to the intended 1.9.7 machine.
Reply | Threaded
Open this post in threaded view
|

Re: Checksum mismatch with 1.9.7

Michael Knigge-2
Hi,


I was able to restore the Dump on a system running 1.9.3.


Tomorrow I'll try to transfer the 1.9.3 repository it to the intended
1.9.7 machine and start using svnsync on that new repository.... Hope
this goes well until we'll switch over in production...


Bye,

Michael