Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Ravi Roy
Hi, 

I've successfully built subversion 1.6 on CentOS 5.9 in past and using it for years now., now we plan to upgrade it to Subversion 1.9.5.

Version of CentOS is also upgraded to 7 but i'm getting the following error while I run :

sudo ./autogen.sh
buildcheck: checking installation...
buildcheck: autoconf version 2.69 (ok)
buildcheck: autoheader version 2.69 (ok)
buildcheck: libtool version 2.4.2 (ok)
buildcheck: local copy of find_apr.m4 does not match APR's copy.
            An updated copy of find_apr.m4 may need to be checked in.
buildcheck: local copy of PrintPath does not match APR's copy.
            An updated copy of PrintPath may need to be checked in.
buildcheck: local copy of find_apu.m4 does not match APRUTIL's copy.
            An updated copy of find_apu.m4 may need to be checked in.
./autogen.sh: line 83: cd: /bin/../share/aclocal: No such file or directory
/libtool.m4 not found (try setting the LIBTOOL_M4 environment variable)

I've tried setting the LIBTOOL_M4 variable to /usr/bin/libtool but does not help.

Does somebody faced this issue in past? I've also tried to google it but does not get a concrete answer. 

Regards
Ravi.


Reply | Threaded
Open this post in threaded view
|

Re: Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Daniel Shahaf-2
Ravi Roy wrote on Wed, 07 Jun 2017 20:14 +0530:
> I've successfully built subversion 1.6 on CentOS 5.9 in past and using it
> for years now., now we plan to upgrade it to Subversion 1.9.5.
>
> Version of CentOS is also upgraded to 7 but i'm getting the following error
> while I run :
>
> sudo ./autogen.sh

Why are you running autogen.sh?  If you build from a released tarball,
you don't need to run autogen at all; just configure and make.  (And
none of them needs to be run as root)

Running autogen.sh is only needed when building from a working copy of
/repos/asf/subversion/tags/*/.
Reply | Threaded
Open this post in threaded view
|

Re: Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Ravi Roy


On Wed, Jun 7, 2017 at 8:32 PM, Daniel Shahaf <[hidden email]> wrote:


Why are you running autogen.sh?  If you build from a released tarball,
you don't need to run autogen at all; just configure and make.  (And
none of them needs to be run as root)

Running autogen.sh is only needed when building from a working copy of
/repos/asf/subversion/tags/*/.
Thanks Daniel, I've used ./autogen.sh in 1.6.x compilation too, there was no specific reason (did not go into details, sorry). I just tried to confiure it but i'm getting the below error :

 ./configure --prefix=/usr/local/Subversion --enable-shared --with-apxs=/usr/local/Apache2/bin/apxs
configure: Configuring Subversion 1.9.5
configure: creating config.nice
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking if gcc accepts -std=c90... yes
checking if gcc accepts -w... yes
checking if gcc accepts -Werror=unknown-warning-option... no
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking how to run the C preprocessor... gcc -E
checking for a sed that does not truncate output... /usr/bin/sed
configure: error: cannot run /bin/sh build/config.sub

Googling it does not give a solid clue. Do you know what is wrong here?
From the INSTALL docuemnt i've made sure all necessary dependencies are installed.

Regards
Ravi
Reply | Threaded
Open this post in threaded view
|

Re: Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Daniel Shahaf-2
Ravi Roy wrote on Wed, 07 Jun 2017 21:45 +0530:
> checking for a sed that does not truncate output... /usr/bin/sed
> configure: error: cannot run /bin/sh build/config.sub
>
> Googling it does not give a solid clue. Do you know what is wrong here?
> From the INSTALL docuemnt i've made sure all necessary dependencies are
> installed.

I'm guessing you ran configure in the same directory you had earlier
attempted to run autogen.sh in?  That'd explain why config.sub is
broken.  Try extracting the tarball again (to a new directory) and
run configure in that (new) tree.
Reply | Threaded
Open this post in threaded view
|

Re: Can not compile Apache subversion 1.9.5 on CentOS 7 (64 bit).

Ravi Roy

On Wed, Jun 7, 2017 at 10:30 PM, Daniel Shahaf <[hidden email]> wrote:

I'm guessing you ran configure in the same directory you had earlier
attempted to run autogen.sh in?  That'd explain why config.sub is
broken.  Try extracting the tarball again (to a new directory) and
run configure in that (new) tree.

Thanks Daniel, great, I'm able to configure, compile and install it on my server now, Thanks again for your quick support, 
Have a great day.
Regards
Ravi.