Bug report: An error occurred during authentication

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug report: An error occurred during authentication

Jan Marti

Bug report: Now i installed Windows 10 x64 Pro a new virtualisation host system which also has a role as reverse proxy with IIS to use "Windows Authentication", before i used Windows 7 x64 Pro. The settings on the SVN apache webserver virtual machine are still the same...

 

But now, with Win10 instead of Win7 as reverse proxy, i get that error message:

 

"An error occurred during authentication"

 

 

- The SSL certificate is not from an offcial certificate issuer, it's generated by Win10 IIS

- The login is 100% correct, when i visit the URL in the browser i see the SVN directories

 

- I also tried:

- Disabling the "RequestFilteringModule" in IIS -> does not work

- Disabling IIS "Compression of static contents" -> does not work

 

- The other "special" settings of apache SVN are the following

- Disabling "mod_deflate"

- Enabling "mod_headers" and adding that line the svn vhost: RequestHeader edit Destination ^https: http: early

 

 

The SVN client seems tob e unable to do the same thing that browsers do, because it works on ALL BROWSERS!!

 

Regards,

Jan

Reply | Threaded
Open this post in threaded view
|

Re: Bug report: An error occurred during authentication

Daniel Shahaf-2
Jan Marti wrote on Sun, 06 Jan 2019 00:32 +0100:
> But now, with Win10 instead of Win7 as reverse proxy, i get that error
> message:
>
>  
>
> "An error occurred during authentication"

Check the error logs of both the proxy server and the backend httpd
server for more detailed error messages.